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Creating Accessible Electronic Content
This resource is designed to be printed as a one page PDF file. An HTML
version is also available below.

The following handout provides general recommendations for creating accessible
content. For program-specific instructions (e.g., Microsoft Word, PowerPoint,
Adobe Acrobat) see our other cheatsheets.

Write clearly
• Use the simplest language appropriate for your content.
• Use illustrations, icons, etc. to supplement text.
• Check spelling, grammar, and readability.
• Be careful with abbreviations, jargon, complex language, or anything that
might confuse the reader.
• AVOID THE USE OF ALL CAPS. IT CAN BE DIFFICULT TO READ.

Use good semantic structure
• Organize your content using true headings (sometimes labeled as “H1”
“Heading 1”, etc.). The document title should be a first-level heading, the next
level should be second-level, etc. Avoid skipping levels (e.g., jumping from
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first-level to third-level headings).

• Use true bulleted and numbered lists rather than creating it by using the
tab key and an asterisk or number.
• Provide a table of contents for long documents.
• Provide a descriptive document or page title.
• Use true columns instead of other methods (e.g., using the “Tab” key to
create columns one line at a time).

Remember users with visual disabilities
• The use of color can enhance comprehension, but do not use color alone to
convey information (e.g., “Items in red are due this week”). Using color is fine
(e.g., “The items due this week have the red word ‘due’ next to them”), it just
can’t be the only way information is provided.
• Make sure that color contrast is strong, especially between text and
background. This is true for images that include text as well.

Insufficient

Borderline

Sufficient
• Do not use descriptions that rely only on sight (e.g., “click on the square”,
“the box on the left side of the page”, “The big blue text”).
• Use adequate text size, usually no smaller than 10 point.

Be careful with data tables
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• If the tools allow provide headers for data tables.

• Use the simplest table structure possible. Be careful with spanned rows or
columns and avoid multiple levels of table headers.
• Avoid using tables for visual layout when possible.

Provide appropriate alternative text
• Many tools allow you to provide alternative text for images. These boxes are
sometimes labeled with phrases like “alt text,” “alternative,” or even
“description.” If present, use this field to provide alternative text.
• Alternative text should present the content and function, not necessarily a
description, of an image. If you had to remove the image, what text would you
put in its place?
• If an image has no relevant content or function, is decorative, or the
alternative text is provided in nearby text, then the image should have
empty alternative text if possible (some tools have an option for “blank” or
“empty”). If this is not an option, leave the field blank. You should not put
empty spaces, empty quotes (except in HTML alt=""), or any other nonsense
information in these fields.
• Avoid words like “picture of,” “image of,” or “link to.”
• Use the fewest number of words necessary.

Ensure links are descriptive
• Avoid phrases like “Click here”, “Here”, “More”, “More information”, “Read
more”, and “Continue.”

Not descriptive
Descriptive
• URL’s as link text should usually be avoided, unless the document is intended
to be printed or if the URL is relevant content.

Caption and/or provide transcripts for media
• Videos and live audio must have captions and a transcript. A transcript is
sufficient for archived audio.
• Captions should be accurately reflecting the text in the video. The text should
be equivalent.
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Creating Accessible Microsoft Word 2007/2010
Documents
This resource is designed to be printed as a one page PDF file. An HTML version is also available
below.

Headings
Create a uniform heading structure through use of styles in Word. This allows screen readers to
navigate a document, and improves accessibility for everyone.

Adding and Editing Headings
Headings can be created using the Styles toolbar.
1. Select
the
text
and
click
on the appropriate style (e.g. “Heading 1”).
2. Headings 1, 2, or 3 can also be assigned using Ctrl + Alt + 1, 2, or 3, respectively.

Alternative Text for Images
Images can be given appropriate alternative text in Word. This Alt text is read by a screen reader in
a Word file and should remain intact when exporting to HTML or PDF.
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Word 2007
1. Right-click on the image and select Size.
A dialog box will appear.
2. Select the Alt Text tab, and replace the
filename with appropriate alternative text.

Word 2010
1. Right-click on the
image and select
Format Picture. A
dialog box will
appear.
2. Select the Alt Text
tab on the sidebar.
Enter appropriate Alt
text to the
Description field, not
the Title field.

Columns
When creating columns, always use true columns,
not columns created by hand with the Tab key.
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Creating Columns
1. Select Page Layout on the Ribbon.
2. Select Columns in the Page Setup group.

Data Tables
• Use the Insert Table command to create tables, not by hand with spaces or the Tab key.
• There is no way to easily create table headers in Word.
• The first row can be identified as table headers in PDF (but not in HTML). To do this, Right click on the
first row in the table and select Table Properties > Row > Repeat as header row at the top of each
page.

Links
Word automatically creates a hyperlink when a user pastes a full URL onto a page. These may not make
sense to screen reader users, so more information is needed.

Editing Hyperlinks
1. Select a hyperlink, right click, and select Edit Hyperlink or Ctrl + k.
2. Change the text in the Text to Display field to a more meaningful description.

http://ncdae.org/resources/cheatsheets/word2010.php

4/20/2018

Microsoft Word 2007/2010 (Windows)

Page 4 of 5

Lists
Use true numbered and bulleted lists to emphasize a
point or a sequence of steps.

Creating Lists
1. Select Page Layout on the Ribbon.
2. Select Bullets and Numbering.

Word 2010 Accessibility Checker
Word 2010 includes an
accessibility resource that
identifies and repairs
accessibility issues.

Running the
Accessibility Checker
1. Select File > Info > Check
for Issues > Check
Accessibility.
2. The checker presents
accessibility errors,
warnings, and tips on
how to repair the errors.

Other Principles
• Ensure that font size is sufficient, around 12 points.
• Provide sufficient contrast.
• Don’t use color as the only way to convey content.
• Provide a table of contents, especially for long documents.
• Use simple language.
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Creating Accessible Spreadsheets in
Microsoft Excel 2010/13 (Windows) &
2011 (Mac)
This resource is designed to be printed as a one page PDF file. An HTML
version is also available below.

Screen readers and Excel
Users who are blind rely on software called a screen reader to interact with
spreadsheets.
• Screen readers will read the cell number as users navigate from cell to cell
(e.g., “Grand Total A 23").
• Spanned cells will be identified by a screen reader (e.g., “Budget A1 through
G1”). If content spans multiple cells visually, these cells should be merged.
To merge cells, select Home and the Merge menu.

Merged cells should not be used in tables. They can be confusing for screen
reader users who expect one row and/or column header for each cell.
• A screen reader user will usually start with the first cell (A1), so this is a
good place to put important information about the sheet.
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• Be careful with empty rows and columns. While they may sometimes be
necessary to visually separate data, they can cause a screen reader user to
think the sheet has ended, even when it has not.

Images and Charts
• While images can be given alternative text in the same way as other Office tools
(see other cheatsheets), they can sometimes introduce reading order issues
and should typically not be added to spreadsheets.
• Charts cannot be given alternative text. Ensure the data used to create the
chart is available and clearly structured, and preferably precedes the chart.

Other principles
• Spell check is not automatic as it is in Word/PowerPoint. Make sure to spell
check each sheet.
• Do not use color alone to convey information.

Inaccessible

Accessible

Table ‘Headers’
If your spreadsheet includes tables, there is a special way to add table ‘header’
information that will be read in some screen readers. Tables can be identified with
formula names of Title, TitleRegion, and others.
• These formulas do not update when the table changes, so be sure your
table is complete first.
• This only works for a single level of headers. Complex tables will need to be
simplified or restructured.

One table per sheet:
For sheets with one table only, select the cell in the upper-left corner of the table
(not the table title).

In Windows, select Formulas> Define Name and the New Name dialog opens.
In Mac, select Insert> Name> Define and the Define Name dialog opens.
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In the Name field, replace the existing text with one of the following 3 values,
depending on your table layout:
If the table has column and row headers, enter Title
If the table has row headers only, enter RowTitle
If the table has column headers only, enter ColumnTitle

Don't Confuse "Column" and "Row" headers. Remember that ColumnTitle is for
vertical headers and RowTitle is for horizontal headers. Also be sure to type
RowTitle or ColumnTitle as one word, without a space.
After entering the correct value in the Name field, select Ok. Although the initial
text is still visible, accessibility information has been added for a screen reader user.
Only add a Name to the first cell in the table. Do not repeat this step for other
header cells within the same table.

Multiple tables per sheet:
If a single sheet has multiple tables, if the table has sortable columns, or if you
want to specify an explicit beginning and end of a table, you need to use
TitleRegion.
Select the cell in the upper-left corner of the table (not the table title). In
Windows, select Formulas> Define Name and the New Name dialog opens. In
Mac, select Insert> Name> Define and the Define Name dialog opens.
In the Name field, enter TitleRegion followed by the following 4 values (no
spaces, separated by periods):
1. Unique number within the sheet (e.g., 1 for the first table)
2. First (upper-left) cell in the table (e.g., A2)
3. Last (lower-right) cell in the table (e.g., C5)
4. Sheet number (e.g., 2 for the second tab in the workbook)

http://ncdae.org/resources/cheatsheets/excel.php

4/20/2018

Microsoft Excel 2010-2013

Page 4 of 4

The above table Name would be TitleRegion1.A2.C5.2
Note: RowTitleRegion or ColumnTitleRegion can be used for tables that only
have row or column headers.
After entering the correct value in the Name field, select Ok. This table is now
accessible. Repeat this process for every table on the sheet, remembering to
select the upper-left corner cell of each new table.

Deleting formula names
You may occasionally create a formula name for the wrong field or give a single cell
more than one name. These unnecessary formula names should be removed.
1. To remove formula names in Windows, select Formulas> Name Manager. In
Mac select Insert> Name> Define.

2. Then choose the desired name and select Delete.
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Creating Accessible Microsoft PowerPoint
2007/2010 Presentations (Windows)
This resource is designed to be printed as a one page PDF file. An HTML version is also available
below.

Slide Layouts
Using slide layouts provided within PowerPoint will ensure that files have correctly structured headings
and lists, and proper reading order.

Creating Slide
Layouts
1. Select Home > New
Slide, or select the
New Slide button
from the default
toolbar.
2. Choose from the
slide options menu
the desired layout.
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Alternative text for Images
Images can be given appropriate alternative text in PowerPoint. This Alt text is read by a screen
reader in a PowerPoint file and should remain intact when exporting to HTML or PDF.

PowerPoint 2007
1. Right-click on the image and select Size
and Position. A dialog box will appear.
2. Select the Alt Text tab, and replace the
filename with appropriate alternative text.

PowerPoint 2010
1. Right-click on the
image and select
Format Picture. A
dialog box will
appear.
2. Select the Alt Text
tab on the sidebar.
Enter appropriate Alt
text to the
Description field, not
the Title field.
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Data Tables
• PowerPoint can style rows and columns so they appear as data tables, but there is no way to add
content in a way that will be identified by a screen reader.
• If your presentation contains more than the simplest tables, and if you have Adobe Acrobat, consider
saving your presentation to PDF and adding the additional accessibility information in Acrobat Pro.

Links

PowerPoint automatically creates a hyperlink when a user pastes a full URL onto a page. These may not
make sense to screen reader users, so more information is needed.

Editing Hyperlinks
1. Select a hyperlink, right click, and select Edit Hyperlink or Ctrl + k.
2. Change the contents in the Text to Display field to a more meaningful description.

Outline and Notes Panels
PowerPoint contains two panels that can be used to enhance accessibility: the Outline panel and the Notes
panel.

Outline Panel
• The Outline panel contains a text outline of the content that appears in your slides.
• Reviewing this panel can help ensure the content on the slides is logically sequenced, that slide titles
are unique and meaningful, and that reading order is appropriate for any user.

Notes Panel
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• The Notes panel allows the speaker to add notes and information that will not appear on the slides.
This information may not be accessed by a screen reader, so do not put important information in this
area.

PowerPoint 2010 Accessibility Checker
PowerPoint 2010 includes an accessibility resource that identifies and repairs accessibility issues.

Running the Accessibility Checker
1. Select File > Info > Check for Issues > Check Accessibility.
2. The checker presents accessibility errors, warnings, and tips on how to repair the errors.

Other Principles
• Ensure that font size is sufficient. If your presentation will be viewed on a projector, font size may
need to be even larger.
• Provide sufficient contrast. If your presentation will be viewed on a projector, sometimes the contrast
needs to be even more pronounced.
• Do not use color as the only way to convey content.
• Avoid automatic slide transitions.
• Use simple slide transitions when possible.
• Use simple language.
• Check reading order of text boxes that are not part of the native slide layout. They are usually the
last thing read by a screen reader.
• If you have embedded video, ensure that the video is captioned, and that the player controls are
accessible.
• If you have embedded audio, include a transcript.
• If your slides contain animations, ensure that they are brief and do not distract from the most
important content on the page.
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Creating Accessible PDF Documents
In Adobe Acrobat X
This resource is designed to be printed as a one page PDF file. An HTML
version is also available below.

Tags Pane
PDF tags provide accessibility information to screen readers. They should not impact
the look of the PDF. To view and edit tags, do the following.
1. Select View > Show/Hide > Navigation Panes > Tags.
2. Select the Options menu> Highlight Content. This allows you to see what
content is associated with a tag.
3. In the Tags panel, expand <Tags> and <Sect> to view and navigate your list
of tags.
4. Navigate through the tags using the up/down arrow keys, and expand and
collapse tags with the left/right arrow keys.
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Find Tag From Selection
1. Click the Select Tool icon and select a portion of text, an image, or a table.
2. Select the Options menu at the top of the Tags panel and then select Find
Tag From Selection. The appropriate tag will be highlighted in the tags panel.

Modifying Tags
1. Right-click the tag you want to change and select Properties, and then the
Tag tab.
2. Selecting the appropriate new tag type from the drop-down list labeled Type.

Tagging an Untagged Document
1. To add tags to an untagged document, choose Tools from the right-hand
menu.
2. Select Accessibility > Add Tags to Document.
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TouchUp Reading Order
The TouchUp Reading Order tool allows a user to quickly add and edit PDF tags
and view the reading order of elements on the page.

TouchUp Reading Order Tool
1. From the right-hand menu, select Tools.
2. Then select Accessibility > TouchUp Reading Order. If the Accessibility
option is not listed, use the Options button to check Accessibility on the
menu.
3. When selected, the view on the screen changes. All of the content is enclosed
in numbered boxes. Each of these boxes represents a tag and the number
corresponds with the reading order in the Order panel.
4. Within the TouchUp Reading Order window you will notice a group of buttons
with the names of several common tags. You can use these buttons to assign
tags to selected text or objects.

Adding/Changing Tags
1. To select content that needs editing, drag a box around an element using the
crosshairs cursor or select everything within a box by clicking on the number
in the top-left corner.
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2. Once you have selected a new element, you can assign some of the most
common tags to that element by clicking on one of the buttons (e.g.,
“Heading 1”). Acrobat will place the selected content in the appropriate tag.
3. Assign alternate text to images by right-clicking on the image and choosing
Edit Alternate Text.

Order Panel
The order panel allows you to change the reading order of the page content so
it matches the visual reading order.
1. To open the Order panel, select Show Order Panel in the TouchUp Reading
Order tool.
2. To change the reading order of an element, click and drag the tag to the
location that reflects the correct reading order.

Alternative Text
When an image is tagged as a figure the alternative text appears over the top of
the image.
1. To add or change text, Right click on the image, select Edit Alternate Text.
2. Enter the appropriate alternative text in the dialog box.

Table Inspector
The Table Inspector allows you to easily identify and assign scope to table
headers.
1. With the TouchUp Reading Order tool open, select a table and then select
Table Inspector.
2. Right click on a selected cell(s) and choose Table Cell Properties. A dialog
box will appear.
3. If the selected cell(s) needs to be tagged as a header, select the Header Cell
option and assign a scope of either Row or Column.

Artifacts
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Artifacts are elements that are ignored by a screen reader. Important text should
never be labeled as an artifact.
1. With the TouchUp Reading Order tool open, select an element you wish to
change to an artifact and press the background button. Or right click on an
item in the Tags panel, and select Change Tag to Artifact.
2. To search for artifacts, go to the Tags panel and select Options > Find.
Artifact is the default search option, so click Find.
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Creating Accessible Adobe InDesign
CS5.5 PDF Documents
This resource is designed to be printed as a one page PDF file. An HTML
version is also available below.

Reading Order
The Articles panel allows you to organize the content reading order of your
document within InDesign.
1. From the control panel, select Window> Articles.
2. Select the Create New Article icon at the bottom of the Articles panel. Name
the article and select the Include When Exporting option.

3. Assign the correct reading order by clicking objects within your document and
dragging them into the Articles panel, under the corresponding Article
section. Multiple objects can also be selected by shift clicking the items in the
order you want them to appear.
4. Rearrange the reading order by dragging objects within the Articles panel to
their correct location.
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5. In the Articles panel menu, check the Use for Reading Order in Tagged PDF
option.

Adding Alternative Text
Alternative text must be applied to images so that the information displayed can
be described by a screen reader.
1. From the control panel, select Object> Object Export Options. Select the Alt
Text tab.
2. With an image selected, choose Custom from the Alt Text Source menu.
3. Enter the appropriate alternative text.

4. The Object Export Options dialogue box can remain open while different images
are selected, and alternative text assigned.

Tagging PDF
Apply a tag to selected images in InDesign to define what their role will be in
Acrobat.
1. Within the Object Export Options, select the Tagged PDF tab.
2. Under the Apply Tag menu, choose Based on Object and InDesign will
automatically assign the tag that best corresponds with that object.

3. Only choose Artifact if the object should be ignored by a screen reader.
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Anchoring Objects within Text
Anchoring images as objects at the appropriate point in the text helps establish an
accessible flow of content.
1. Click and hold the small blue box located at the top of the image.

2. Drag to the point in the text that makes sense in the reading order.

Page Title
Once the file is exported to Acrobat, it is important for the PDF to have certain
information attached to the file.
1. From the File menu, select File Info. Select the Description tab.
2. Enter the Document Title.

Export Tagging with Styles
InDesign can use your paragraph styles to map InDesign styles to PDF tags.
Tables, bulleted and numbered lists, footnotes, and hyperlinks are tagged
accurately and automatically, so all that is necessary to assign is your heading
styles. (E.g. H1, H2, etc.)
1. In the Paragraph Styles menu, select the Edit All Export Tags option.
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2. Make sure that PDF is selected in the Show options at the top of the dialogue
box.
3. Click on the text that reads [Automatic] and use the dropdown to select the
heading level that corresponds to each style.

Exporting to PDF
1. From the File menu, select Export.
2. Under Save as Type, select Adobe PDF (Interactive).
3. In the Settings page, check the Create Tagged PDF option.

Made possible by a grant from the Fund for the Improvement of Postsecondary
Education (FIPSE), US Department of Education. No official endorsement implied.
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Identifying Web Accessibility Issues
This resource is designed to be printed as a one page PDF file. An HTML version is
also available below.

Video Tutorial

While it takes a fairly technical background to detect all accessibility issues and features,
there are many accessibility problems that can be quickly and easily identified without the
need for a highly technical background. This handout will suggest a few free accessibility
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tools and offer 4 simple techniques to help you identify some common web accessibility
problems.

1. Use the WAVE tool to detect errors
WAVE (wave.webaim.org) is a free online tool that can help you evaluate your page for
accessibility. WAVE places color-coded icons over the page you are testing. While it takes
some skill to interpret some icons, you can be sure that any red icon is an accessibility
error to be addressed.
• If you are not sure what an icon means, click on it and then select "More

information".
• If you cannot see the icons correctly, select the No Styles button to view the page
without styles. Although the page will look different, all icons should be visible.

• You can also click on the Contrast button to identify text with low contrast that may
be difficult for some people to read.

2. Navigate without a mouse
Some users with motor disabilities, as well as those who are blind, have difficulty
navigating the web using a mouse. Because of this, all web content must be accessible
using the keyboard only. To test this, use the Tab key to navigate through links and
forms (Shift + Tab to go backward) and the Enter key to perform an action. If you can't
get to what you want, or if your cursor gets trapped and can't move, the page has an
accessibility problem.
Note: If you are using Safari, you will need to enable the following preference first: Safari
> Preferences > Advanced > Check "Press Tab to highlight each item on a
webpage".
Check for the following issues:
• When you 'Tab' to a link with the keyboard it should be highlighted, usually with a
dashed outline. If you don't see this outline this is a serious issue.

• Ensure that the keyboard navigation order is logical. It should basically match the
visual reading order of the page. (e.g., header, sidebar, main content, footer).
• Check for things that only work with a mouse (e.g., a navigation menu that expands
when the user hovers over it with a mouse). See what happens if you try to navigate
this same area with a keyboard.
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• Some pages have a link at the beginning of the page that allows users to skip over
top navigation to the main content on the page, navigate to this link with Tab and
then press Enter to activate the link. Ensure that the screen visually 'jumps' over the
navigation to the beginning of the page. Hit Tab again and make sure that focus goes
to the next link on the page. If it jumps back to the top of the page, or if focus never
moves from the top of the page in the first place, the skip link might be broken.

• If any boxes pop open (e.g., slideshows, date pickers, warnings) make sure you can
navigate and close these boxes with a keyboard. The Esc key should close these boxes
as well.

3. Zoom a page and enlarge text
Some users with visual disabilities enlarge page content for readability, but enlarging
content on a page can sometimes cause layout problems. To make content larger, press
Ctrl (Cmd on Mac) and + (plus). Ctrl and - (minus) makes content smaller and Ctrl and
the number 0 will return to the default. Zoom the page several times and make sure
everything is readable, especially images with text. It is fine if a horizontal scroll bar
appears at the bottom of your window.
By default, zooming enlarges everything on the page, including images, but some users
only enlarge text, so test this as well. To enlarge only text, do one of the following:
• Safari: View > Zoom Text Only
• Firefox: View > Zoom > Zoom Text Only
• Internet Explorer: View > Text size

Then, enlarge the page at least 150%, and up to 200% (roughly 4-5 steps) and make
sure none of the text becomes hidden or unreadable. It is fine if text wraps to a new line
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or if the page doesn't look the same.

100%

150%

200%

4. Other Recommendations to help you detect
accessibility issues
• Check videos for captions.
• Look for links with generic link text such as "click here" or "more info." These types
of links can be confusing to screen reader users, and should be replaced with more
descriptive link text.
• Check the page title (the text that appears in your browser tab) and make sure that it
is unique and descriptive.

• Contact individuals with disabilities and see if they would be willing to review the
site and identify issues they encounter.
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